cancel
Showing results for 
Search instead for 
Did you mean: 

Installation of Prognosis-Client-11 parallel to old Prognosis-Client

Community Manager

Installation of Prognosis-Client-11 parallel to old Prognosis-Client

Hello Experts!

in Release 10 it was possible to start installation with a parameter so that we could parallel install Prognosis-Clients.
Today I use Prognosis-9 and a Prognosis-10.3 on my client. Now we need additional Prognosis-11-Client, but:

The Prognosis Setup Wizard told me:
Prognosis Setup has found multiple versions of Prognosis.
Prognosis setup cannot proceed; please refer to the Prognosis installation Guide

How can I do that? Confused

BR
Bernd
4 REPLIES 4
Community Manager

Re: Installation of Prognosis-Client-11 parallel to old Prognosis-Client

Hi Bernd,

I have some good news and bad news in this regard.

Bad News: There is no way to get multiple versions of the GUI and/or server installed on the same server anymore. This is a deliberate limitation.

The Good News: As of 10.3 onwards we made the GUI backwards compatible meaning that you can use a later version GUI to directly access an older version server. Rule of thumb is 3 dot releases.
i.e.
10.5 GUI can connect to 10.4 & 10.3 and 10.2 servers

Unfortunately There is not much that can be done for 9.x.
- Please be aware that 9.x is end of life so you should be thinking about upgrades on those ones.

One other thing: Most configuration actions for 11.x servers can be done in the Webui Administration now. Maybe you might not need the GUI as much as previously and using the onbox GUI for the rare tasks that you do need it is viable. (I.e. 11.1 now supports starting/stopping and some configuration to Thresholds etc)

Let me know if the above helps answer this question.
Community Manager

Re: Installation of Prognosis-Client-11 parallel to old Prognosis-Client

Hi Adam,

thanks for the real interessting answer.

I guess that means that I must work with a virtualised windows-instance to use the new Prognosis-Windows-Client.
Which windows-Version is the minimum for the Prognosis 11 Client?

BR Bernd
Community Manager

Re: Installation of Prognosis-Client-11 parallel to old Prognosis-Client

Hi Bernd,

The following online help topic has a complete list:
http://help.prognosis.com/dr/Prognosis_11-1/mergedProjects/Installation/HTML_Files/Installation/Windows_Client/Install_WindowsClient-SystemRequirements.htm?zoom_highlight=requirements+windows+client

Microsoft Windows 7 (x86 and x64)
Microsoft Windows 8 (x64)
Microsoft Windows 10 (x64)

MS Windows Server 2008-SP2 (x86 and x64)
MS Windows Server 2008 R2-SP1 (x64)
MS Windows Server 2012 (x64)
MS Windows Server 2012 R2 (x64)

I hope my previous post didn't cause too much confusion. I was just basically confirming that mutliple WIndows Client installs to the same server are not possible. I also thought it good to add info on some added flexibility to the windows client and that the future is to edit everything in the webui.
Community Manager

Re: Installation of Prognosis-Client-11 parallel to old Prognosis-Client

Thank you Adam,

it is how it is. And your information was really helpfull.
Thank you.
See you hopefully later in some other cases :-)

BR,
Bernd
Blog: What Optimal Transaction Performance Means

A number of our customers use Prognosis to monitor the health of their payment systems. As part of this, they monitor the transactions flowing through the system ...

Read blog
Top Liked Members