cancel
Showing results for 
Search instead for 
Did you mean: 

Web Application

Anon
Community Manager

Web Application

Hello,
I want to use the RestAPI on the Monitoring Server but the Web Application was not installed at the beginning.
Is the Web Application can be installed after Prognosis is already installed.

Regards,
10 REPLIES 10
ChristopherS
12 Sherpa

Re: Web Application

There is a not so great work around to install the Web server after the fact that I am immediately aware of.. it is actually easier to do an upgrade from like 11.3 and 11.4 and let it install it at that time if that is an option. Like wise if you want to only install the WebUI on a server but not Prognosis the installer doesn't let you do it.

I have not personally tried this, but you 'may' be able to install it on another server, copy the WebUI folder, over to the other server, export the IIS configuration from the other server, then install the cfg on the other server and it might work at least minimally for your purposes.

If my answer helped you today, please be sure to mark the resolved button to assist others.

Christopher R Souser - Solution Architect – MSci. PA, CISSP, ITIL.
Anon
Community Manager

Re: Web Application

Thanks Christopher for idea.
This could be work. I will let you know.

Re: Web Application

Alain,

Another option would be to still use your managing node for RestAPI. When you create REST objects, just create Views that are collecting data from specific monitoring node.

Regards,
Shoaib.

If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib
Anon
Community Manager

Re: Web Application

Hi Shoaib,

The RestAPI request came from the customer network and cannot access the Managing Node.

Regards,

Re: Web Application

Let us know what approach you took and if it worked for you.

If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib
Anon
Community Manager

Re: Web Application

Hi,

The MN server was installed with Prognosis 10.4 and Web application. Then we did an upgrade to Prognosis 11.2 without Web application.
Yesterday I copied the entire WEbUI folder from another MN Prognosis 11.2 and I also copied the PersistviewsUI_user.xml and RestApiDataSets.xml.
After I restarted the IIS services IrPrognosisSite.

The WebUI work well but the RestAPI always return HTTP 500 Internal Server Error.

If you have any idea.

Re: Web Application

Can you also try the rest api link in a brower 'After you have logged into Web'.

It could look like: https://localhost/Prognosis/rest/v1/data/

The above link, if works, should list all the available objects. If it returns 200 OK but no object, then it could be that view is not generated properly in the server. You can also try to run the pql query in the rest xml file on ..\irpqcli and see if data is returned. May be the persistent view you copied from other server is not valid (e.g node or nodegroup doesn't exists or something?

If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib
Anon
Community Manager

Re: Web Application

Hi,

Yes I already test with the Command line ..\irpqlcli and it return the data. But any request from browser like https://localhost/Prognosis/rest/v1/data/ return error HTTP 500.
Anon
Community Manager

Re: Web Application

Hello

No more error HTTP 500. Instead of using IE I successfully using Firefox.