cancel
Showing results for 
Search instead for 
Did you mean: 

Prognosis supported SHA authentication versions for SNMPv3

Timon_Dennis
06 Trekker

Prognosis supported SHA authentication versions for SNMPv3

Hi,

Wondering if you can tell me what version(s) of the SHA authentication protocol Prognosis supports for SNMPv3 polling?  Couldn't find anything in online documents or in the Community.  We're currently testing migrating our Oracle SBCs from SNMPv2 to v3 for polling and running into issues with the SBCs correctly receiving the authentication.  This isn't limited to Prognosis as we'e experiencing same with another NMS tool we're testing with.  Oracle support believe this may be a compatibility issue with the SHA versions available to configure on the SBC (256 and 512) and what the tools we are testing with are sending for version.  Not convinced that is the issue, but hoping to rule it out.

 

Thanks!

Tim

1 ACCEPTED SOLUTION

Accepted Solutions
Adam_Annen
Community Manager

Re: Prognosis supported SHA authentication versions for SNMPv3

Hi Tim,

 

As of Prognosis 11.9 Patch 4, our NET-SNMP is on 5.7.3 and therefore cant support SHA-192 and higher. We are working on NET-SNMP 5.9 right now but this is a large change that will require a lot of work and testing to release.

 

For now, using SNMPV3 is possible offcourse but you will be limited to SHA strength below SHA-192.

I think this question might come up for other customer's so thank you for raising it. I have posted a quick FAQ here on it:

https://community.ir.com/t5/Collaborate/Does-Prognosis-support-snmp-settings-with-SHA-192-and-above-...

 

Regards

Adam

View solution in original post

1 REPLY 1
Adam_Annen
Community Manager

Re: Prognosis supported SHA authentication versions for SNMPv3

Hi Tim,

 

As of Prognosis 11.9 Patch 4, our NET-SNMP is on 5.7.3 and therefore cant support SHA-192 and higher. We are working on NET-SNMP 5.9 right now but this is a large change that will require a lot of work and testing to release.

 

For now, using SNMPV3 is possible offcourse but you will be limited to SHA strength below SHA-192.

I think this question might come up for other customer's so thank you for raising it. I have posted a quick FAQ here on it:

https://community.ir.com/t5/Collaborate/Does-Prognosis-support-snmp-settings-with-SHA-192-and-above-...

 

Regards

Adam

View solution in original post