cancel
Showing results for 
Search instead for 
Did you mean: 

Error: Error #0, Message: CREATE DATABASE permission denied in database 'master'., Source: .Net SqlC

Support_Sydney
Moderator

Error: Error #0, Message: CREATE DATABASE permission denied in database 'master'., Source: .Net SqlC

Your UC Reporter data is not summarizing and you see the below error in the IPTMR-summary.txt log file:

Error #0, Message: CREATE DATABASE permission denied in database 'master'., Source: .Net SqlClient Data Provider, Sysmessages table index: 262

1 ACCEPTED SOLUTION

Accepted Solutions
GeraldC1
Community Manager

Re: Error: Error #0, Message: CREATE DATABASE permission denied in database 'master'., Source: .Net

Your UC Reporter data is not summarizing and you see the below error in the IPTMR-summary.txt log file:

Error #0, Message: CREATE DATABASE permission denied in database 'master'., Source: .Net SqlClient Data Provider, Sysmessages table index: 262

 

Cause: Each SQL user is assigned to a default database and sql assigns this to 'master' by default. If your user has sa role rights, then no further action is required, but if your user is restricted to either public or public + dbcreator, then specific permissions to this 'master' database are needed.

Solution: You have 3 options:

1. Change the default database for your user to IPTM_Device instead (Which it should already have enough permissions to).
or
2. In SQL Management Studio go to the Security\Logins section and bring up the properties for your user. Click into user mapping and click on the master database and give db_datareader permission to this database for your user.
or
3. Give your user the 'sa' role

Note: All 3 of these settinsg are set in SQL Management Studio

View solution in original post

1 REPLY 1
GeraldC1
Community Manager

Re: Error: Error #0, Message: CREATE DATABASE permission denied in database 'master'., Source: .Net

Your UC Reporter data is not summarizing and you see the below error in the IPTMR-summary.txt log file:

Error #0, Message: CREATE DATABASE permission denied in database 'master'., Source: .Net SqlClient Data Provider, Sysmessages table index: 262

 

Cause: Each SQL user is assigned to a default database and sql assigns this to 'master' by default. If your user has sa role rights, then no further action is required, but if your user is restricted to either public or public + dbcreator, then specific permissions to this 'master' database are needed.

Solution: You have 3 options:

1. Change the default database for your user to IPTM_Device instead (Which it should already have enough permissions to).
or
2. In SQL Management Studio go to the Security\Logins section and bring up the properties for your user. Click into user mapping and click on the master database and give db_datareader permission to this database for your user.
or
3. Give your user the 'sa' role

Note: All 3 of these settinsg are set in SQL Management Studio

View solution in original post