cancel
Showing results for 
Search instead for 
Did you mean: 

ELM licence usage data report is not populating

PhanindraAtchi
10 Guide

ELM licence usage data report is not populating

Hello Team,

 

I could not able to retrive the licence information report from the Reports tab. I see cluster details are also not showing on the report page. Please help to how to trouble shoot and get this data populated.

Licence usage.JPG

 

 

 

 

 

 

 

Regards,

Phani

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ELM licence usage data report is not populating

@PhanindraAtchi you are right, only 9 and above.

 

image.png


If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib

View solution in original post

9 REPLIES 9

Re: ELM licence usage data report is not populating

 

Hey @PhanindraAtchi,

can you try to run the below command from WebUI node and see what you get?

 

..\irpqlcli "SELECT Vendor, Type, TopLevelName from AppStartIpTelephonyGenericRecordView" -r

This report is looking for clusters with Vendor as 'Ci' and Type as 'C5'. do you get any that match this crietaria? If you are not getting anything back, try restarting PrognosisSite from IIS.

 

image.png


If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib
PhanindraAtchi
10 Guide

Re: ELM licence usage data report is not populating

Hi Shoib,

 

I got below output .

shoib1.JPG

 

 

 

 

Regards,

Phani

Re: ELM licence usage data report is not populating

Hey @PhanindraAtchi It confirms that you have atleast 1 cluster that should appear in the drop down.

 

The other thing I'd check is if it is due to RBS. Can you run the below query to see what Customer it belongs to.

 

..\irpqlcli "SELECT Customer, Vendor, Type, TopLevelName from AppStartIpTelephonyGenericRecordView" -r 

 

And then, for your Role, that you are logged in with, does it have specific CUSTOMERS associated? If so, you'll have to make sure it includes the customer returned in above query.

 

image.png


If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib
PhanindraAtchi
10 Guide

Re: ELM licence usage data report is not populating

Hi Shoib,

I have executed below query and got the output as below:

rr1.JPG

 

 

 

 

And i have verified in admin page its looks like it was configured with Role Public. Please look into this and let me know if any changes should required.

rr3.JPG

 

 

 

 

 

rr2.JPG

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Thanks,

Phani

Re: ELM licence usage data report is not populating

@PhanindraAtchi, Is it possible that your username is also part of the 'Royal' RBS? Can you confirm what Customers 'Royal' has access to? And if it is using 'specific', the above mentioned customer is checked?


If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib
PhanindraAtchi
10 Guide

Re: ELM licence usage data report is not populating

Hi Shoib,

 

The username which we are using for this customer is "prognosis" and we are not configured username as Royal for any customer and all the customers are in different subnets which we monitor individually. And i also wants to inform tha this issue persists only the Report Tab : ELM licence usage . Remaining all the are workking normally.

 

Thanks,

Phani

Re: ELM licence usage data report is not populating

@PhanindraAtchi,

 

another thing I just noticed is that it specifies version 9 and greater. Can you confirm that for the below query what version you are getting?

..\irpqlcli "SELECT Customer, Vendor, Type, MajorSoftwareVersion, TopLevelName from AppStartIpTelephonyGenericRecordView" -r

 

The report description says "Cisco Enterprise License Manager (ELM) related user and unassigned device license usage (applicable to Cisco Unified CM version 9.0 and higher)"

 


If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib
PhanindraAtchi
10 Guide

Re: ELM licence usage data report is not populating

Hi shoib ,

 

This call manager version is 8 . So , This ELM usage report will work only on version 9 or above?

 

rrversion.JPG

 

 

 

 

 let me know still any report tabs will not work under this verison.I will check with my customer for upgrade.

 

Thanks,

Phani

 

 

 

Re: ELM licence usage data report is not populating

@PhanindraAtchi you are right, only 9 and above.

 

image.png


If my reply answered your question please click on the 'Accept as Solution' button to help others find the answer.
Thanks,
Shoaib

View solution in original post